Phone System Outage
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted Aug 08, 2022 - 15:06 CDT
Identified
We are currently experiencing issues with call routing which is preventing outside calls from reaching our support center. Teams are aware of the issues and are working towards a resolution
Posted Aug 08, 2022 - 13:04 CDT
This incident affected: Contact Center (Telephone issues).