Launch Electronic Signature Issue
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted May 08, 2020 - 17:07 CDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 08, 2020 - 16:54 CDT
Investigating
We are investigating reports of errors within the Electronic Signature sections of Launch. Users may experience errors or timeouts while attempting to collect electronic signatures. Please retry if you receive this error. Engineers are investigating.
Posted May 08, 2020 - 16:36 CDT
This incident affected: Boarding API.