Compass Reporting Anomalies
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted Jan 25, 2020 - 15:08 CST
Identified
Compass users: we are working to address any reporting anomalies related to your transactions, and ensure that your accurate transaction history and funding will return to normal as soon as possible. The integrity of your data is important to us and we appreciate your patience while we insure its accuracy.
Posted Jan 24, 2020 - 15:48 CST
This incident affected: Legacy Compass (Legacy Compass Reporting).