Bank Holiday Reminder (Thanksgiving Day)
Incident Report for Clearent
Resolved
As a reminder, Thursday, Nov. 25th is a bank holiday. Funds will be deposited the following business day.
Posted Nov 29, 2021 - 09:56 CST
Monitoring
As a reminder, Thursday, Nov. 25th is a bank holiday. Funds will be deposited the following business day.
Posted Nov 24, 2021 - 11:21 CST
Investigating
As a reminder, Thursday, Nov. 25th is a bank holiday. Funds will be deposited the following business day.
Posted Nov 24, 2021 - 11:21 CST
This incident affected: Express Merchant Funding (Next Day Funding), Standard Merchant Funding, and Merchant Home.