Transaction Processing for Newly Boarded Merchants
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted Feb 23, 2021 - 08:58 CST
Investigating
We have become aware that our upstream partner is experiencing system issues which may impact transactions for newly boarded merchants. We will track closely with them and report their progress.
Posted Feb 22, 2021 - 16:03 CST
This incident affected: Transaction Authorization.