Delayed Funding
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted Oct 06, 2020 - 16:46 CDT
Identified
Merchants with express merchant funding (EMF) with batches closed between 8pm and 10pm on 10/5/2020 Central time may experience delayed funding. We anticipate that funds will be made available to deposit accounts on 10/6/2020 by end of business, depending on your financial institution's deposit processes.
Posted Oct 06, 2020 - 00:54 CDT
This incident affected: Express Merchant Funding (Next Day Funding).