Contact Center Inbound calls - Network issues
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted Nov 13, 2019 - 14:03 CST
Monitoring
Recovery is under way. However our vendors indicate there could still be residual or degraded performance. We are monitoring the situation as they are. Thank you.
Posted Nov 13, 2019 - 12:53 CST
Update
We are continuing to investigate this issue.
Posted Nov 13, 2019 - 12:38 CST
Investigating
We are experiencing network difficulties with our Networked Phone provider. Calls are being delivered, however many of our agents are having trouble connecting to the application which delivers the call. Please be patient as wait times could be extended, or leave a callback message and you calls will be returned in the order they were received. Thank you.
Posted Nov 13, 2019 - 12:32 CST