Merchant Funding Delays
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted Apr 02, 2021 - 13:06 CDT
Monitoring
A downstream issue has been identified. Merchants impacted should receive their funds tomorrow.
Posted Mar 29, 2021 - 15:17 CDT
Identified
Some merchants are experiencing delays with their deposits. We have confirmed Clearent's request for funding went out as expected. We are working with our banking providers to determine root cause and potential downstream issues. We will update as soon as additional information becomes available.
Posted Mar 29, 2021 - 13:59 CDT
This incident affected: Express Merchant Funding (Next Day Funding) and Standard Merchant Funding.