Merchant Funding Delays
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted Sep 14, 2021 - 08:49 CDT
Update
We are continuing to work on a fix for this issue.
Posted Sep 14, 2021 - 08:45 CDT
Identified
Some merchants who participate in our Next Day Funding service will experience a delay with today's deposit. This issue generally impacts merchants who batched out on Monday, September 13th. Merchants who are on Clearent's standard funding schedule do not appear to be impacted by this issue.
Posted Sep 14, 2021 - 08:43 CDT
This incident affected: Express Merchant Funding (Next Day Funding).