Compass Incident

Incident Report for Xplor Pay

Resolved

This incident has been resolved.
Posted Aug 26, 2026 - 09:40 CDT

Monitoring

We have become aware of intermittent connectivity issues with Compass starting at 5:36pm EDT and resolving at 7:20pm EDT. While services are restored, teams are continuing to monitor and research to identify root cause. We will provide further updates as they become available.
Posted Aug 22, 2026 - 19:08 CDT
This incident affected: Legacy Compass (Legacy Compass Portal, Legacy Compass Reporting).