DDA Visibility Issue

Incident Report for Clearent

Resolved

Merchants are now able to view their DDA if needed. The issue has been resolved.
Posted May 20, 2022 - 23:01 CDT

Identified

It has been discovered that a small number of merchants are unable to view their DDA information in Merchant Home.

The visibility issue began on May 13th and is expected to be corrected by EOD May 23rd.

This issue has had no effect on funding or any systems operations.
Posted May 20, 2022 - 16:07 CDT

Monitoring

It has been discovered that a small number of merchants are unable to view their DDA information in Merchant Home.

The visibility issue began on May 13th and is expected to be corrected by EOD May 23rd.

This issue has had no effect on funding or any systems operations.
Posted May 20, 2022 - 16:06 CDT
This incident affected: Merchant Home.