E-Signature unavailable

Incident Report for Clearent

Resolved

This incident has been resolved.
Posted Sep 24, 2021 - 14:41 CDT

Investigating

E-Signature is currently not available. Teams are researching this now.
Posted Sep 24, 2021 - 14:15 CDT