Discover Authorizations
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 13:08 CDT
Investigating
We have been made by one of our partners that merchants may be experiencing timeouts when attempting transactions using a Discover card. The partner has indicated that teams are working on the issue and we will provide updates as they become available.
Posted Mar 21, 2023 - 09:45 CDT
This incident affected: Transaction Authorization.