Degraded Phone Service
Incident Report for Clearent
Resolved
This incident has been resolved.
Posted Apr 23, 2024 - 08:10 CDT
Identified
We have been notified by our telecom service of intermittent network issues that may cause connection failure on calls to our contact center. The problem is being reviewed by technical teams. We will provide updates as they become available.
Posted Apr 22, 2024 - 13:18 CDT
This incident affected: Contact Center (Telephone issues).